Compile & Run EasyAR Unity Samples

This article shows how to run EasyAR unity samples.

*If you want to setup EasyAR Unity projects using EasyAR.unitypackage, please read this instead.

Pre-Requirements

Unity 4.6 or later

(If target for Android) Android SDK with Build Tools at least version 20.0.0

(If target for iOS) IPhone or IPad device, or other real Apple devices (EasyAR do not support running on the simulator)

Open Sample

First you need to open unity sample project and open the scene in the sample.

Unity 4 is like bellow,

And Unity 5 like this,

Additional for Unity 5, after open the project, follow Unity instructions to upgrade the project, then you can use it with no difference compared to Unity 4.

Enter Key

Find "EasyAR" object and Enter "Key" in the inspector. Initialize will fail if a valid key is not provided.

Follow the instructions in the TextArea to fill the key.

All is done! You can now run the Unity sample on all platforms including Windows/Mac/Android/iOS.

XCode configure

*If you are using latest Unity, this step is automatically done by Unity.

When you are generating iOS apps, after the automatic build step which put everything from Unity to XCode, you need one more step to make all things work.

XCode 6.x: add libc++.dylib into linker libraries.

XCode 7.x: add libc++.tbd into linker libraries. And Set Enable Bitcode to NO.